В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SQQQUAD
SQQQUAD
06.09.2021 22:38 •  Информатика

Задача 1. Напишите программу, которая в последовательности натуральных чисел определяет сумму двузначных чисел, оканчивающихся на 5. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 5. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число — сумму двузначных чисел, оканчивающихся на 5.

Задача 2 Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, оканчивающихся на 2 и среднее значение суммы таких чисел. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 2. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести два числа — количество чисел, оканчивающихся на 2 и среднее значение суммы таких чисел. Если таких чисел нет, то программа должна вывести «No».

Ответ:
серик26
серик26
22.04.2020 20:30

var n,i,a,s: integer;

begin

write('Введите количество чисел в последовательности: ');

readln(n);

for i := 1 to n do

begin

write('Введите число: ');

readln(a);

if a mod 3 = 0 then s:=s+a;

end;

writeln('Сумма чисел, кратных 3, равна: ',s)

end.

Вторая задача

var

i,n:1..100;

a:-300..300;

s:-30000..30000;

begin

s:=0;

read(n);

for i:=1 to n do begin

read(a)

if a mod 10=3 then s:=s+a;

end;

write(s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?