В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Evelina17890
Evelina17890
22.06.2021 03:06 •  Информатика

1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read (с,b); If (с>b) or (b mod 2=0) then а:=b+2 else а:=с div 3; Writeln(a); End.
2)Напишите программу решения задачи. Дано число n. Если оно не кратно 3 или равно числу b, то вывести число n, увеличенное на 2, иначе найти 18% от числа b.
3)Напишите программу решения задачи. Дано двузначное число а. Если последняя цифра этого числа больше первой, то вывести число а, уменьшенное на 100.

Ответ:
Іра022
Іра022
13.10.2020 15:53

Задание 2, 3 во вложении

Объяснение:

Задание 1.

Сначала вводятся переменные b и с через пробел.

Мы вводим сначала с, оно равно 205, и затем b, оно равно 204.

затем идет условие.

Если с>b или b mod 2=0

Если 205>204 или

b mod 2=0 - это означает, число b кратно 2, то есть при делении на 2 оно должно дать 0.

В нашем случае 204/2=102 , то есть число 204 кратно 2, оно поделилось на него без остатка.

Первое и второе условие сработало, а значит выполняется следующее:

a:=b+2;

То есть в переменной а мы к b прибавляем 2. И у нас выходит:

a:=204+2=206

Условие иначе у нас не работает, поэтому выводим:

Writeln(a);

Программа выведет число а

206.


1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
1)Чему равно значение а после выполнения программы, если с=205 b=204 Var a,b,c: integer; Begin Read
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?