В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
Fenef
Fenef
17.10.2020 09:07 •  Информатика

за решение через for
Напишите программу, которая запрашивает число N, а затем считает сумму чисел от 1 до N включительно, т.е. 1+2+3...+N.

Ответ:
terrabyte
terrabyte
13.10.2020 14:25

уточняйте на каком языке программирования нужно написать.

Для примера напишу на С++, но алгоритм будет тот же везде

//Создаем переменные n и sum

int n = 0;

int sum = 0;

//Вводим число n с клавиатуры.

cout << "Введите n: ";

cin >> n;

//Создаём цикл от 0 к числу которое мы ввели(включая его)

//Считаем сумму всех чисел которые идут до этого числа

for(int i = 0; i<=n; i++){

sum = sum + i;

}

//Выводим нашу сумму

cout << "Сумма: " << sum;

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?