В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Hartfilia
Hartfilia
28.02.2021 08:13 •  Информатика

8.На вход программе подается натуральное число в конце которого стоят нули. Отрежьте от правого края числа все нули. В ответ выведите полученное число.Питон

Ответ:
диля252
диля252
13.10.2020 14:35

a=list(input())

while a[-1]=='0':

   del a[-1]

print(''.join(a))

Объяснение:

Не оптимально конечно, но работает

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?