В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Программа паскаль.
написать программу:
имеется целочисленный массив из 100 элементов
1) вывести на экран через запятую все элементы имеющие чётный индекс;
2) вывести на экран построчно все элементы имеющие нечётный индекс.

Ответ:
ник5045
ник5045
13.10.2020 13:50

var anarray: array[1..100] of integer;

   i: integer;

begin

   Randomize;

   for i := 1 to 100 do // заполняем массив рандомными числами

       anarray[i] := random(100);

   for i := 1 to 100 do // выводим на экран элементы массива с четным индексом

   begin

       if (i + 1 > 100) then Write(anarray[i])

       else

           if (i mod 2 = 0) then Write(anarray[i], ', ');

   end;

   for i := 1 to 100 do // выводим на экран элементы массива с нечетным индексом

       if (i mod 2 <> 0) then WriteLn(anarray[i]);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?