В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LerikKerik123
LerikKerik123
07.05.2022 16:41 •  Информатика

Составить программу вычисления площади и периметра прямоугольного треугольника, если заданы его катеты. Катеты ввести с клавиатуры.

Вначале вычислить гипотенузу треугольника, а затем посчитать площадь и периметр.

С операторов ввода ввести катеты, в разделе описания переменных задать тип для всех переменных, используемых для решения данной задачи (катеты, гипотенуза, площадь и периметр).

Ответ:
molik111105
molik111105
13.10.2020 13:28

pascal

Объяснение:

var

 a, b, c: real;

 s, p: real;

begin

Write('Введите катеты треугольника: '); ReadLn(a, b);

c := sqrt(sqr(a) + sqr(b));

p := a + b + c;

s := a * b / 2;

WriteLn('Периметр треугольника равен ', p:3:2);

WriteLn('Площадь треугольника равна ', s:3:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?