В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
shumilovakate
shumilovakate
14.04.2023 02:23 •  Информатика

Напишите программу, которая заполняет массив из 20 элементов случайными трёхзначными числами и находит в нём элемент, у которого наибольшая сумма цифр, и его но мер. С++ ТОЛЬКО СИ ++

Ответ:
Алтын12938849к9ку9
Алтын12938849к9ку9
26.01.2024 16:34
Хорошо, я могу помочь вам написать программу на языке C++, которая будет решать данную задачу.

Прежде всего, мы должны понять, как заполнить массив случайными трёхзначными числами. Для этого нам понадобится библиотека случайных чисел , а также функции rand() и srand(). Давайте создадим функцию, которая будет заполнять массив случайными трёхзначными числами:

```cpp
#include
#include
#include

void fillArray(int array[], int size)
{
srand(time(0)); // Инициализация генератора случайных чисел

for (int i = 0; i < size; i++)
{
array[i] = rand() % 900 + 100; // Генерация случайного трёхзначного числа
}
}
```

Далее, нам нужно создать функцию для вычисления суммы цифр числа. Для этого мы будем считать остатки от деления числа на 10, чтобы получить каждую цифру, и затем суммировать их. Давайте создадим соответствующую функцию:

```cpp
int digitSum(int number)
{
int sum = 0;

while (number > 0)
{
sum += number % 10; // Получение цифры числа
number /= 10; // Убираем последнюю цифру числа
}

return sum;
}
```

Теперь мы можем создать главную функцию программы, которая будет находить элемент массива с наибольшей суммой цифр. В этой функции мы вызовем функцию fillArray(), чтобы заполнить массив, затем пройдемся по всем элементам массива, находя сумму цифр каждого числа и запоминая индекс элемента с максимальной суммой:

```cpp
int main()
{
const int size = 20;
int array[size];

fillArray(array, size);

int maxSum = 0;
int maxIndex = 0;

for (int i = 0; i < size; i++)
{
int sum = digitSum(array[i]);

if (sum > maxSum)
{
maxSum = sum;
maxIndex = i;
}
}

std::cout << "Число с наибольшей суммой цифр: " << array[maxIndex] << std::endl;
std::cout << "Наибольшая сумма цифр: " << maxSum << std::endl;

return 0;
}
```

Вот и весь код программы. Теперь, при запуске программы, она заполнит массив из 20 случайных трёхзначных чисел, найдет число с наибольшей суммой цифр и выведет его на экран, а также выведет саму наибольшую сумму цифр.

Надеюсь, мой ответ вам помог! Если есть ещё вопросы, не стесняйтесь задавать.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?