В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Ф
Физика
Э
Экономика
М
Математика
Г
География
И
Информатика
Ф
Французский язык
М
МХК
О
Окружающий мир
Н
Немецкий язык
П
Психология
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
А
Английский язык
Б
Биология
Қ
Қазақ тiлi
masha1248
masha1248
10.03.2023 09:41 •  Информатика

Напишите программу, которая 10 раз выводит на экран ваши имя и фамилию тремя а) for б) while в Сегодня сдавать

Ответ:
ivanrumyantsev1
ivanrumyantsev1
13.10.2020 12:53

var i:integer;

   name:string;

begin

 writeln('Введите свое имя');

 readln(name);

через For: ');

 for i := 1 to 10 do

   write(name + ' ');

 i := 1;

 writeln();

через While: ');

 while i < 11 do begin

   write(name + ' ');

   i := i + 1;

 end;

 i := 1;

 writeln();

через repeat..until: ');

 repeat

   write(name + ' ');

   i := i + 1;

 until i > 10;

end.

0,0(0 оценок)
Ответ:
AutWezer
AutWezer
13.10.2020 12:53

Через WHILE:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

i:=1;

while (i<=10) do begin

writeln(s);

i:=i+1;

end;

end.

Через REPEAT:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

i:=1;

repeat

begin

writeln(s);

i:=i+1;

end;

until (i>10);

end.

Через FOR:

var s: string;

var i: integer;

begin

write('Введите ваше имя: ');

readln(s);

for i:=1 to 10 do writeln(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?