В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
4okoladka100
4okoladka100
22.02.2022 16:24 •  Информатика

Дан массив d состоящий из n элементов. Найдите максимальный элемент массива и его порядковый номер.
Напишите программу.

Ответ:
Strong996
Strong996
12.10.2020 22:41

d=[]

for i in range(int(input())):

   d.append(int(input()))

print(max(d))

print(d.index(max(d)))

0,0(0 оценок)
Ответ:
Sidi123
Sidi123
12.10.2020 22:41

В объяснении

Объяснение:

Из задания не совсем ясно, необходимо ли в программе производить ввод массиве, если нет, то решение следующее:

# Максимальный элемент массива

_max = max(d)

# Порядковый номер элемента

_index = d.index(_max)

# Вывод

print(_max, _index)

Если запрещено использовать встроенные функции, то:

# первый элемент - максимальный

_max = d[0]

_index = 0

# Цикл по всем элементам

for i, x in enumerate(d):

   # Если элемент больше максимального

   if x > _max:

       _max = x

       _index = i

# Вывод

print(_max, _index)

Если необходимо произвести и ввод, то в начале задачи надо дописать:

n = input('Введите n: ')

d = []

for x in range(n):

   d.append(input('Введите число: '))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?