В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sofamalaya
sofamalaya
21.01.2021 12:14 •  Информатика

Напишите программу, в которой осуществляется ввод целых чисел до тех пор, пока не будет введена единица, и подсчет произведения положительных чисел, используя оператор repeat

Ответ:
спеш
спеш
13.10.2020 12:04

var a,s: integer;

begin

s:=1;

repeat

write('Введите число: ');

readln(a);

if (a>0) then s:=s*a;

until a=1;

writeln('Произведение положительных чисел: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?