В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rasimallamurato
rasimallamurato
22.04.2022 05:19 •  Информатика

Написать программу на паскале
рассматривается множество целых чисел, принадлежащих отрезку [200; 9120], которые делятся на 8 и не делятся на 7, 11, 17 и 19. Найдите количество таких чисел и минимальное из них. В ответе запишите два числа через пробел: сначала количество, затем минимальное число.

Ответ:
ksuhamalinovskaj
ksuhamalinovskaj
13.10.2020 11:55

var cnt,min,i: integer;

begin

min:=0;

cnt:=0;

for i:=200 to 9120 do

 begin

 if (i mod 8 = 0) and (i mod 7 <> 0)

 and (i mod 11 <> 0) and (i mod 17 <> 0)

 and (i mod 19 <> 0) then  

   begin

   if (min=0) then min:=i;

   cnt:=cnt+1;

   end;

 end;

writeln(cnt,' ',min);

end.

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?