В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
LimOonka
LimOonka
24.08.2020 05:42 •  Информатика

Задача1.Составить программу обработки массива размерностью n, заполненного целыми числами, введенными с клавиатуры. Вывести индексы и значения положительных элементов массива.

Ответ:
zeka27
zeka27
13.10.2020 00:12

var

 arr:array[1..1000] of integer;

 i,n:integer;

begin

 write('Укажите размер массива - ');

 read(n);

 

 writeln;

 

 for i:=1 to n do

 begin

   read(arr[i]);

 end;

 for i:=1 to n do

   if arr[i]>0 then writeln('Эл-т - ',arr[i],' Номер - ',i);

 

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?