В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sona272
sona272
04.07.2020 16:10 •  Информатика

Напишите программу, которая суммирует все числа в диапазоне от 4 до 32 и вычисляет их среднее арифметическое, выводит эти числа на экран в строчку и на отдельных строках выводит сумму и среднее арифметическое

ОЧЕНЬ ВАЖНО! ДАМ ВЫСШУЮ НАГРАДУ

Ответ:
Zolotareva1981
Zolotareva1981
13.10.2020 00:27

var  

 S,SA:real;

 i,k:integer;

begin

 S:=0;

 

 SA:=0;

 

 for i:=4 to 32 do

 begin

  S:=S+i;

  k:=k+1;

 end;

 SA:=S/k;

 

 write('Sum = ',S,'   Arithmetic mean = ',SA);

end.  

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?