В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
sveta05011
sveta05011
01.03.2021 19:09 •  Информатика

Напишите программу, в которой даны три действительных числа. Возвести в квадрат положительные числа и в четвертую степень - отрицательные c#

Ответ:
NastiaForever18
NastiaForever18
13.10.2020 10:58

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           double a, b, c;

           Console.WriteLine("Введите a:");

           a = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите b:");

           b = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("Введите c:");

           c = Convert.ToDouble(Console.ReadLine());

           Console.Write("Результат: {0} , {1}, {2}", (a > 0) ? a * a : a * a * a * a,

               (b > 0) ? b * b : b * b * b * b, (c > 0) ? c * c : c * c * c * c);

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?