В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
filltema
filltema
20.08.2022 01:17 •  Информатика

Составить программы в PascalABC:

1. Составить программу нахождения произведения цифр вводимого с клавиатуры четырёхзначного числа. (Например, число 2351, результат 30).

2. Составить программу нахождения среднего арифметического квадратов двух чисел, введённых с клавиатуры. (Например, числа 2 4, результат 10)

Ответ:
деш2
деш2
13.10.2020 10:37

Задача 1:

var a,s: integer;

begin

write('Введите четырёхзначное число: ');

readln(a);

s:=1;

while (a>0) do

 begin

 s:=s*(a mod 10);

 a:=a div 10;

 end;

write('Произведение цифр введённого четырёхзначного числа: ',s);

end.

Задача 2:

var a,b: integer;

var s: real;

begin

write('Введите два числа: ');

readln(a,b);

s:=(a*a+b*b)/2;

write('Среднее арифметическое квадратов двух введённых чисел: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?