В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
gerger10
gerger10
21.09.2021 06:21 •  Информатика

Заранее Написать программу для решения задач на Pascal ABC:

Даны три различных целых числа. Найти среднее из них. (Средним называется число, которое больше наименьшего и меньше наибольшего из данных чисел)
Найти наибольшее из трех заданных чисел.

Ответ:
smail550
smail550
13.10.2020 10:09

Первый вариант:

program N60286025;

var a,b,c,m:integer;

begin

write('Введите 1-е число: ');

readln(a);

write('Введите 2-е число: ');

readln(b);

write('Введите 3-е число: ');

readln(c);

if (a <= b) and (b <= c) or (a >= b) and (b >= c) then m := b;

if (b <= a) and (a <= c) or (b >= a) and (a >= c) then m := a;

if (c <= b) and (a <= c) or (c >= b) and (a >= c) then m := c;

writeln('Среднее число ',m);

readln

end.

Второй вариант:

program N60286025;

var a,b,c,m:integer;

begin

write('Введите 1-е число: ');

readln(a);

write('Введите 2-е число: ');

readln(b);

write('Введите 3-е число: ');

readln(c);

if a <= b then

if a <= c then

if b <= c then

m := b

else

m := c

else

m := a

else

if a <= c then

m := a

else

if b <= c then

m := c

else m := b;

writeln('Среднее число ',m);

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?