В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Still06
Still06
25.01.2021 09:30 •  Информатика

Написать программу и начертить блок-схемы решения задач:
Дан массив вещественных чисел, состоящий из 10 элементов. Найти максимальный элемент массива.

Ответ:
Ильха1
Ильха1
13.10.2020 09:52

попробуй это. Тут еще с нахождением его номера

var a:array[1..100] of real;

    i,imax,n:integer;    

max:real;

begin

write('N= ');

readln(n);

for i:=1 to n do     read(a[i]);

writeln('');

imax:=0;

max:=a[1];

for i:=1 to n do     if a[i]>max then

begin max:=a[i];imax:=i;

end;

writeln('max = ',a[imax],' nomer = ',imax);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?