В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ahmed0051
ahmed0051
05.02.2020 21:56 •  Информатика

Напишите программу на языке Паскаль, которая при вводе положительного числа утраивает его значение, при вводе отрицательного числа увеличивает его на 10 единиц, при вводе 0 уменьшает его на 2 единицы.

Ответ:
Noop1
Noop1
13.10.2020 08:06

pascal

Объяснение:

program prog1;

var

 a: real;

begin

 Write('Введите число ');

 ReadLn(a);

 if a > 0 then a := a *3

 else if a < 0 then a := a + 10

 else a := a - 2;

 Write('a = ', a);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?