В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Составить программу, которая меняет у пяти любых чисел, вводимых с
клавиатуры, порядок следования цифр в числе на обратный, используя подпрограмму процедура

Ответ:
bosyakostya
bosyakostya
13.10.2020 06:21

var

n:integer;

begin

repeat

write('N = '); readln(n);

until (n>=100) and (n<=999);

writeln('Было введено число - ',n);

writeln('');

writeln('Младшая цифра - ',n mod 10);

writeln('Средняя цифра - ',n div 10 mod 10);

writeln('Старшая цифра - ',n div 100);

writeln('');

writeln('Перевёрнутое число - ',n mod 10,n div 10 mod 10,n div 100);

end.

1

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?