В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
mishkasega77798
mishkasega77798
18.05.2021 04:51 •  Информатика

Дан одномерный целочисленный массив A[15]. Элементы массива вводятся с
клавиатуры. Написать программу, которая будет находить сумму положительных
элементов массива, стоящих на нечетных местах.

Ответ:
kupeevaaaaa
kupeevaaaaa
30.07.2020 13:05

var A: array [1..15] of integer;

var i,s: integer;

begin

s:=0;

for i:=1 to 15 do

 begin  

 read(A[i]);

 if (A[i]>0) and (i mod 2 <>0) then s:=s+A[i];

 end;

writeln('Сумма положительных',

' элементов массива, стоящих на нечетных местах: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?