В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Svetik200611
Svetik200611
04.09.2022 21:13 •  Информатика

ПАСКАЛЬ Дан одномерный массив A[10]. Элементы массива – это случайные числа большие 0.
Написать программу, которая будет находить произведение элементов массива,
лежащих в интервале [20, 70].

Ответ:
cudak
cudak
23.08.2020 20:14

var i,s: integer;

begin

s:=1;

randomize();

for i:=1 to 10 do

 begin

 A[i]:=random(100);

 write(A[i],' ');

 if (A[i]>=20) and (A[i]<=70) then

 s:=s*A[i];

 end;

writeln();

writeln('Произведение элементов массива: ',s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?