В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
theslomsmon
theslomsmon
21.10.2022 12:34 •  Информатика

Написать программу, которая вычисляет среднее арифметическое первых n членов последовательности 1, 3, 5, 7, …, n. Количество n задается во время работы программы.
Среди двухзначных чисел найдите и выведите на экран числа, сумма цифр которых делится на 13.

Ответ:
Love25252525
Love25252525
13.10.2020 00:46

ответ:1, 3, 5, 7, ... - арифметическая прогрессия, в которой первый член a1=1 и разность d=7-5=5-3=3-1=2.

запишем формулу n члена прогрессии:

an=a1+d(n-1)=1+2n-2=2n-1, где n - номер члена последовательности.

Составляем программу:

var n,s,i: integer;

begin

readln(n);

s:=1;

for i:=2 to n do s:=s+2*i-1;

write('сумма: ',s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?