В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
pomidorka0078
pomidorka0078
21.04.2021 13:23 •  Информатика

Составить блок-схему алгоритма. Определить тип алгоритма. Составить программу на языке программирования Паскаль.

Ответ:
соняпросоня
соняпросоня
12.10.2020 23:01

const

 e = 2.718;

var

 y, x: real;

begin

 writeln('Введите значение x:');

 write('x = ');

 read(x);

 if x = 2 then

 begin

   y := e * e * e * e;

   writeln('y = ', y:0:3);

 end

 else

 begin

   if (x < 2) then

     y := 4 * x * x - 7;

   if (x > 2) then

     y := abs(x - 1);

   writeln('y = ', y);

 end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?