В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
FROST1234567891011
FROST1234567891011
16.08.2020 19:21 •  Информатика

Составить программу на Pascal.
Дан прямоугольник, длины сторон которого a и b представляют собой натуральные числа. Составить рекурсивную программу-функцию, подсчитывающую, на сколько квадратов с натуральными длинами сторон можно разрезать исходный прямоугольник, если каждый раз от него отрезать квадрат максимально возможной площади.​

Ответ:
dsayui56
dsayui56
23.08.2020 19:28

Pascal ABC.

Код:

var

  a, b: integer;

function sko(a, b: integer): integer;

begin

    if (a = b)

    then

        sko := 1

    else begin

         if a < b then

            b := b - a

         else

             a := a - b;

         sko := 1 + sko(a, b);

    end;

end;

begin

    readln(a, b);

    writeln(  sko(a, b)   );

end.

Пример действия:

Ввод:

5 4

Вывод:

5

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?