В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Напишите программу на языке Pascal. Дано натуральное число A, в записи которого нет нулей. Требуется найти минимальное двузначное число, которое можно увидеть в записи числа A. Например, для числа 815943 ответом будет 15.​

Ответ:
Yana230600
Yana230600
12.10.2020 17:03

===Pascal ABC.Net===

program ;

var

 number, min, temp :integer;

begin

 min := 100;

 Write('Введите число без нулей: ');

 ReadLn(number);

 while number <> 0 do

 begin

   temp := number mod 100;

   if (temp < min) and (temp div 10 <> 0) then min := temp;

   number := number div 10;

 end;

 Write('Минимальное двузначное число: ', min);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?