В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
SsuccesS
SsuccesS
19.09.2022 19:49 •  Информатика

Питон:В одном из своих видео Маша рассказывает о том, как она провела N дней в Петербурге и о том, сколько денег она тратила на развлечения в каждый из этих дней.

Найдите, на какой по счёту день поездки Маша потратила больше всего денег.

Если дней, когда Маша потратила наибольшую сумму денег, несколько, то выведите номер первого из них.

Формат входных данных
Целое положительное число 1 < N < 1000 - количество дней

N целых положительных чисел < 1000000 - траты в каждый из дней по порядку

Формат выходных данных
Номер дня.

входные данные выходные данные
5
150
120
160
170
270
5
4
100
200
300
300

Ответ:

r=0

m=0

x=0

N=int(input())

for i in range(N):

   x=int(input())

   if x>m:

       r=i+1

       m=x

print(r)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?