В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
medovd
medovd
14.02.2021 05:41 •  Информатика

1. Базовая алгоритмическая структура
разветвления в языке Паскаль — …
Вставьте пропущенные слова.

2. Какие операторы записаны без ошибок?
А) If a> 0 Then x := a Else y: = b;
Б) If a> 0 Then x = a; Else y = b;
В) If a> 0 Then x = a; Writeln (x) else y =
b; Writeln (y)

3. Какое значение будет предоставлено
переменной x в результате выполнения
оператора
If a> 0 Then x: = a + 1 Else x: = 2 * a;
Если значение переменной a равнo 5;
A) -15;
B) 6;
D) 10?
4. Составьте программу, которая
спрашивает пользователя, который час, и
выводит на экран соответствующее
пожелание — «Доброе утро!»,
«Здравствуйте!», «Добрый вечер!» или
«Доброй ночи!». Для каждого пожелания
.выберите соответствующий цвет.
5 Компьютер должен перемножить два
числа - 167 и 121. Если их произведение
превышает 2000, то компьютер должен
напечатать текст ПРОИЗВЕДЕНИЕ
БОЛЬШОЕ, иначе текст ПРОИЗВЕДЕНИЕ
МАЛЕНЬКОЕ. После этого компьютер в
любом случае должен напечатать само
произведение.

Ответ:
teenwolfgrrArina
teenwolfgrrArina
12.10.2020 13:58

1. if

2. A

3. B

4.

var a : integer;

begin

writeln('Который час?');

readln(a);

if (a > 4) and (a < 12) then writeln('Доброе утро')

else if (a >= 12) and (a < 17) then writeln('Добрый день')

else if (a>=17) and (a < 21) then writeln('Добрый вечер')

else if (a >= 21) and (a <= 4) then writeln('Доброй ночи');

end.

5.

var

a : integer := 167;

b : integer := 121;

c : integer;

begin

c := a*b;

if c > 2000 then writeln('Произведение большое')

else writeln('Произведение маленькое');

writeln(c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?