В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ulugbek9i
Ulugbek9i
19.07.2021 17:16 •  Информатика

Составить программу, которая сортирует четыре числа по порядку возрастания и убыванию. Несколько вариантов Через if... Then

Ответ:
рксский
рксский
12.10.2020 11:52

вот программа сортирующая n чисел  

uses crt;  

const nmax=100;  

var a:array[1..nmax] of real;  

n,i,j:integer;  

x:real;  

begin  

clrscr;  

randomize;  

repeat  

write('n=');  

readln(n);  

until n in [1..nmax];  

writeln('Исходный массив: ');  

for i:=1 to n do  

begin  

a:=10*random;  

write(a:5:2);  

end;  

writeln;  

for i:=1 to n-1 do  

for j:=i+1 to n do  

if a<a[j]>;  

a:=a[j];  

a[j]:=x;  

end;  

writeln('Сортировка: ');  

for i:=1 to n do  

write(a:5:2);  

readln  

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?