В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Alina221006
Alina221006
29.01.2023 13:09 •  Информатика

Пользователь программы вводит произвольную последовательность целых
положительных чисел и цифру. Определите, сколько раз в этой
последовательности встречается заданная им цифра?
Пример
Ввод: 11, 25, 55, 111, 75, 505, 2
Вывод: цифра 5 встречается в последовательности в 6 раз

Ответ:
dayn915
dayn915
12.10.2020 11:27

number_list = str(input()).split()

number_ask = str(input('ищем цифру: '))

asked_number_list = []

for n in number_list:

   for i in n:

       if i == number_ask:

           asked_number_list.append(i)

print('число %s встречается ' % number_ask + str(len(asked_number_list)) + str(' раз(а) .'))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?