В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Dania0609
Dania0609
18.05.2021 10:47 •  Информатика

Написать программу на С++
Дан символьный файл f. Получить в файле g все малые латинские буквы файла f.

Ответ:
doloasd
doloasd
12.10.2020 11:12

#include <iostream>

#include <regex>

#include <fstream>

#include <string>

using namespace std;

int main() {

   ifstream fin("f");

   string s = "", _temp;

   while (getline(fin, _temp))

       s += _temp;

   fin.close();

   ofstream fout("g");

   try {

       regex re("[a-z]");

       sregex_iterator next(s.begin(), s.end(), re);

       sregex_iterator end;

       while (next != end) {

           smatch match = *next;

           fout << match.str();

           next++;

       }

   }

   catch (regex_error& e) {

       cout << "smth went wrong.";

   }

   fout.close();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?