В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
дочь20
дочь20
03.11.2020 08:38 •  Информатика

(Python) написать программу, которая считывает числа, вводимые пользователем, пока пользователь не введёт слово “end”. Предполагайте, что пользователь вводит только целые числа или слово “end”. В конце программа должна вывести все введённые числа через запятую и их сумму и среднее значение.
Пример вывода
Enter numbers:
1
10
25
-1
0
3
67
end
You entered: 1, 10, 25, -1, 0, 3, 67
Total: 105
Average: 15.0
Указания:
Используйте цикл while для ввода чисел и сохраняйте их в списке.
Используйте цикл for для подсчёта суммы чисел в полученном списке.

Ответ:
Алёна112345678900
Алёна112345678900
12.10.2020 10:08

lst = []

count = 0

sm = 0

while True:

   try:

       lst += [int(input())]

   except:

       break

print('You entered:', end=' ')

for i in lst:

   sm += i

   count += 1

   if i != lst[-1]:

       print(i, end=', ')

   else:

       print(i)

print(f'Total: {sm}')

print(f'Average: {sm / count}')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?