В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
PRIL82
PRIL82
23.10.2020 09:41 •  Информатика

Написать программу на языке паскаль.
Циклический алгоритм с предусловием задан в виде словесного описания. Заданы начальные значения переменных:
x:=1; y:=5;
Начало цикла. Пока y>x выполнить:
y: = y – x;
k=k+1;
конец цикла;
Определить количество циклов k и значения переменной y после выхода из цикла.
Две переменные k и y, вывести на экран один раз

Ответ:
ivanpanyushkin1
ivanpanyushkin1
12.10.2020 09:01

var

 x, y, k: integer;

begin

 x := 1;

 y := 5;

 k := 0;

 while y > x do

 begin

   y := y - x;

   k := k + 1;

 end;

 Writeln('Количество циклов: ', k);

 Writeln('Значение переменной Y: ', y);

end.

Тестовое решение:

Количество циклов: 4

Значение переменной Y: 1

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?