В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
void1231
void1231
05.10.2021 07:30 •  Информатика

Написать программу с указанным интерфейсом, вычисляющую сумму и среднее арифметическое трех чисел:

Введите три числа:
<Пользователь вводит, например: 6 8 2 >
Сумма = 16 Среднее арифметическое = 5,3333

Ответ:
fionovaa
fionovaa
11.09.2020 22:54

program aeifmerik;

var

a, b, c, d: real;

begin

writeln('введите три числа(если не целые,то с точкой,а не запятой)');

readln(a, b, c);

d := (a + b + c) / 3;

writeln('ваша сумма равна ', a + b + c);

writeln('среднее арифметическое равно ', d: 6: 2);

end.

Объяснение:

если среднее арифметическое нужно округлить,то Можно в последней строчке после д сделать так:

d:6:2

тогда после запятой будет только 2 знака.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?