В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kateshopina0703
kateshopina0703
27.08.2021 11:57 •  Информатика

Составить программу в Паскале для обработки массива из 10 чисел Х = (–17,3; 13,2; –7; –2,36; 123,4; –0,3; 12,356; 142; 0; –1). Вычислить количество элементов массива с нечетными номерами на отрезке [5,1..32,4]. В отчет включить программный код и результат работы программы.

Ответ:
даха144
даха144
12.10.2020 08:05

var A: array[1..10] of real =  

(-17.3, 13.2, -7, -2.36, 123.4, -0.3, 12.356, 142, 0, -1);

var i,cnt: integer;

begin

cnt:=0;

for i:=1 to 10 do

 begin

 if ((A[i]>=5.1) and (A[i]<=32.4) and (i mod 2 <> 0))

 then cnt:=cnt+1;

 end;

writeln('Количество элементов массива с нечетными номерами',

'на отрезке [5,1..32,4]: ', cnt);

end.


Составить программу в Паскале для обработки массива из 10 чисел Х = (–17,3; 13,2; –7; –2,36; 123,4;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?