В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Asyu666
Asyu666
14.12.2020 22:16 •  Информатика

Написать программу на языке PASCAL, реализующую алгоритм решения следующих задач (одной на
выбор):
1. Вывод суммы натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число – сумма всех натуральных чисел от N1 до N2 включительно.
2. Вывод произведения натуральных чисел в заданном диапазоне
Входные данные: N1, N2 – натуральные числа (от 0 до 255), нижняя и верхняя границы
соответственно
Выходные данные: Число –произведение всех натуральных чисел от N1 до N2 включительно.

Ответ:
данила307
данила307
03.09.2020 18:03

Задача 1

var

 i, sum, n1, n2: integer;

begin

 readln(n1, n2);

 for i := n1 to n2 do  

   sum := sum + i;

 writeln(sum);

end.

Задача 2

var

 i, n1, n2: integer;

 p: BigInteger;

begin

 p := 1;

 readln(n1, n2);

 for i := n1 to n2 do  

   p := p * i;

 writeln(p);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?