В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
rufdiana
rufdiana
06.05.2021 00:26 •  Информатика

Информатика в написании программы Написать программу на C# : Дан текстовый файл. Напечатать первый символ каждой строки.

Ответ:
Лерок228
Лерок228
12.10.2020 07:24

using System;

namespace ConsoleApplication

{

   class Program

   {

       static void Main(string[] args)

       {

           using (System.IO.StreamReader sr = new System.IO.StreamReader(@"C:\test1.txt"))

           {

               while (sr.Peek() > -1)

               {

                   try

                   {

                       Console.WriteLine(sr.ReadLine()[0]);

                   }

                   catch { Console.WriteLine("Пустая строка"); }

               }

           }

           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?