В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
ddddsfvxsf
ddddsfvxsf
16.12.2022 23:46 •  Информатика

Написать программу Паскаль дано целое положительное число напечатать количество и сумму его цифр

Ответ:
AnselmaRain
AnselmaRain
12.10.2020 07:19

var

 n, i, count, sum: integer;

begin

 Writeln('Ввидете число: ');

 Read(n);

 count := 0;

 while n <> 0 do

 begin

   i := n mod 10;

   sum += i;

   count += 1;

   n := n div 10;

 end;

 Writeln('Сумма всех цифр: ', sum);

 Writeln('Количество цифр: ', count);

end.

Тестовое решение

Введите число:  

51231

Сумма всех цифр: 12

Количество цифр: 5

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?