В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
alladzyurich
alladzyurich
02.09.2022 17:20 •  Информатика

На языке программирования c# написать программу, которая заполняет массив случайными числами через цикл foreach.

Ответ:
deniskalopatin
deniskalopatin
12.10.2020 06:25

(Для версий C# 7.2 и выше)

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           Span<int> storage = stackalloc int[10];

           Random r = new Random();

           foreach (ref int item in storage)

               item = r.Next(101)-50;

           foreach (ref readonly var item in storage)

               Console.Write($"{item} ");

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?