В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
MissKaprizz99
MissKaprizz99
14.07.2022 15:54 •  Информатика

1. Напишите программу, которая получает с клавиатуры четыре целых числа и находит наибольшее и наименьшее из них.
2. Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение «По росту.», если числа введены по возрастанию (неубыванию), или сообщение «Не по росту!», если они введены в другом порядке.
3. Напишите программу, которая получает с клавиатуры номер месяца и выводит название соответствующего ему времени года или сообщение об ошибке.
4. Напишите программу, которая получает с клавиатуры целое число и выводит ответ на во Верно ли, что было получено трёхзначное число?».
5. Напишите программу, которая получает с клавиатуры трёхзначное число и выводит ответ на во Верно ли, что введённое число – палиндром?» (число-палиндром читается одинаково слева направо и справа налево, например, число 151).
python

Ответ:
Daleton
Daleton
12.10.2020 03:30

1)

number_list = []

for i in range(4):

   number_list.append(int(input()))

print('максимальное число: ' + str(max(number_list)))

print('минимальное число: ' + str(min(number_list)))

2)

first_list = [int(input()) for n in range(3)]

second_list = []

for number in first_list:

   second_list.append(number)

first_list.sort()

if first_list == second_list:

   print('по росту .')

else:

   print('не по росту !')

3)

month_ask = str(input())

if month_ask in ['12', '1', '2', '01', '02']:

   print('Зима .')

elif month_ask in ['3', '4', '5', '03', '04', '05']:

   print('Весна .')

elif month_ask in ['6', '7', '8', '06', '07', '08']:

   print('Лето .')

elif month_ask in ['9', '10', '11', '09']:

   print('Осень .')

4)

number = str(input())

if len(number) == 3:

   print('Верно .')

else:

   print('Не верно .')

5)

number = str(input())

first_list = []

for n in number:

   first_list.append(n)

second_list = []

for i in first_list:

   second_list.append(i)

first_list.reverse()

print(first_list)

print(second_list)

if first_list == second_list:

   print('Верно .')

else:

   print('Не верно')

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?