В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
vladimirshmele1
vladimirshmele1
06.04.2023 04:06 •  Информатика

Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел от 1 до n. В каждой строке надо напечатать очередное число и столько символов “+”, сколько делителей у этого числа. Например, если n = 4, то на экране должно быть напечатано:
1+
2++
3++
4+++

Ответ:
jybais228
jybais228
17.08.2020 19:53

Код на Pascal выводит точно то, что требуешь )). Напомню лишь, не забудь про отступы, когда будешь писать/копировать код. Удачи! )):

var i,j,m,n: integer;

pl{,i_s}: string;

begin

   pl:= '';

   writeln('Enter n: n = ');

   readln(n);

   for i:= 1 to n do

   begin

       for j:= 1 to i do

       begin

           pl:= pl + '+';

       end;

   //i_s:= string(i);

   writeln(i{_s},' ',pl);

   pl:= '';

   end;

end.


Составить программу (в Паскаль через вложенные циклы )для графического изображения делимости чисел о
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?