В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Соня2340
Соня2340
03.07.2020 20:15 •  Информатика

нужно составить программу в паскале
Заранее Задание:
Найдите среднее арифметическое элементов массива, заполненного случайными числами от 6 до 21. Размерность массива вводится с клавиатуры. Вывести на экран все элементы.

Ответ:
Elv26
Elv26
12.10.2020 01:34

PascalABC.Net

Varian 1:

begin  var n := ReadInteger('Введите размер массива');  var a := ArrRandom(n, 6, 21);  Print(a, 'Srednee: ', a.Average); end.

Varian 2:

var  f: array[1..100] of integer;  i, sum, N: integer;  srednee: real; begin  Writeln('Введите размер массива: ');  Read(N);  sum := 0;  randomize;  for i := 1 to N do  begin    f[i] := random(6, 21);    write(f[i], ' ');    sum := sum + f[i];  end;  srednee := sum / n;  writeln('Srednee: ', srednee:3:3); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?