В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Stan0
Stan0
03.07.2022 22:09 •  Информатика

Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляет А^N без использования операции возведения в степень.

Ответ:
Zigmynda11
Zigmynda11
12.10.2020 01:32

a = int(input())

n = int(input())

a1 = a

for k in range (n - 1) :

   a *= a1

print (a)

Объяснение:

Мы вводим два числа и начинаем цикл While, в котором мы каждый раз когда делаем возведение в степень (умножаем число А на самого себя) уменьшаем число N (значащее степень, в которую надо возвести число)

Прикладываю базовые тесты:


Напишите программу на языке Python, которая получает с клавиатуры натуральные числа А и N и вычисляе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?