В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
arty181118
arty181118
11.05.2022 23:17 •  Информатика

Напишите программу, печатающую количество максимальных элементов непустого массива. Язык С++

Ответ:
Lerka0tarelka
Lerka0tarelka
12.10.2020 01:32

#include <iostream>

using namespace std;

int

main ()

{

 int n, i, t = 1, m, a[100]; \\ можно поставить свои ограничения;

 cin >> n;

 for (i = 0; i < n; i++)

   cin >> a[i];

 m = a[0] - 1;

 for (i = 0; i < n; i++)

   {

     if (a[i] > m)

{

  m = a[i];

  t = 0;

};

     if (a[i] == m)

t++;

   };

 cout << t;

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?