В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Grigoof
Grigoof
07.08.2022 11:46 •  Информатика

Составьте программу, проверяющую, является ли последовательность чисел, вводимых с клавиатуры, возрастающей. Язык паскаль, цикл while​

Ответ:
markinaalisa2003
markinaalisa2003
11.09.2020 21:22

var n,t:integer;

   b:boolean;

begin

 b:=true;

 readln(t);

 while true do begin

   readln(n);

   if (n=0) then break;

   if n>t then t:=n

   else b:=false;

 end;

 

 if b then writeln('возростающая')

 else writeln('не возростающая')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?