В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык

Задача No3
Составить программу разложения натурального числа n на множители.
пример: 360 = 2 2 2 3 3 5. Посчитать количество разных множителей.
our
python цикл while​

Ответ:
Raigon
Raigon
11.10.2020 21:48

n = int(input())

divisor = 2

unique = set()

while n > 1:

   if n % divisor == 0:

       print(divisor, end=' ')

       unique.add(divisor)

       n //= divisor

   else:

       divisor += 1

print('\nКоличество уникальных делителей: {0}'.format(len(unique)))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?