В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
natalyasergeev1
natalyasergeev1
05.05.2020 17:16 •  Информатика

Цикл с параметром. Поиск числа.
Напишите программу, которая в последовательности натуральных чисел
определяет минимальное число, оканчивающееся на 4. В программу сначала
Вводится количество чисел, а затем сами числа.
Входные Выходные | Входные Выходные | Входные Выходные
данные данные данные данные | данные данные
14
24
14
20
34​

Ответ:
AlzhanovSalavat
AlzhanovSalavat
11.10.2020 18:17

program min_na_4;

var

i,n,x,m:integer;

begin

read(n);

for i:=1 to n do

begin

read(x);

if x mod 10 = 4

then

if m=0 then

m:=x

else

if m>x then

m:=x

end;

write(m)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?