В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
агата281
агата281
19.04.2021 18:33 •  Информатика

сделать :

1)Исправить ошибки в программе , которая определяет количество отрицательных элементов .массива:

Program M;

Const

N=10;

Var

A: Array[1..N] of integer

I,k:integer;

Begin

For I:=1 To N Then

A[I]:=Random100-50;

if A[i]<0 do k:=k+1

End;

Write(k=,k);

End

2)Расставить в правильном порядке строчки программы , которая находит сумму всех четных элементов массива :

Program M;

constN=10;

Var

S:=0;

I,s : integer;

Begin

If A[i] mod 2=0 then S:=s+A[i];

A[i]:= Trunc Random (101)-50;

End;

For I:=1 To N Do begin

A:Array [1..N] of integer;

Write('s=',s);

End.

3)Написать программу , которая посчитает сумму заработанных командой из 10 человек интеллектуальном турнире по химии . для каждого участника указать рандомными числами в диапазоне от 5 до 20

Ответ:
GiraAronEchwik
GiraAronEchwik
11.10.2020 17:51

1) Program M;

Const N=10;

Var A: Array[1..N] of integer;

I,k:integer;

Begin

For I:=1 To N do begin

A[I]:=Random100-50;

if A[i]<0 then k:=k+1

End;

Write(k=,k);

End.

2)Program M;

const N=10;

Var A:Array [1..N] of integer;

I,s : integer;

Begin

S:=0;

For I:=1 To N Do begin

A[i]:=Random (101)-50;

If A[i] mod 2=0 then S:=s+A[i];

End;

Write('s=',s);

End.

3) Program chemistry;

Const N=10;

Var A: Array[1..N] of integer;

S:integer;

Begin

For I:=1 To N do begin

A[I]:=Random(16)+5;

s:=s+a[i];

End;

Write(s=,s);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?