В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
Ayka557
Ayka557
14.06.2022 00:42 •  Информатика

Паскаль, процедуры и функции
Составить программу, определяющую, в каком из данных двух чисел больше цифр (создать подпрограмму для вычисления кол-ва цифр в числе).

Ответ:
LSP111
LSP111
27.08.2020 22:17

===== PascalABC.NET =====

function КолЦифр(n: integer): integer;

begin

 (n, Result) := (Abs(n), 0);

 while n > 0 do

 begin

   Inc(Result);

   n := n div 10

 end

end;

begin

 var (a, b) := ReadInteger2('Введите два целых числа:');

 case Sign(КолЦифр(a) - КолЦифр(b)) of

   1: Print('В первом числе больше цифр');

   0: Print('В числах одинаковое количество цифр');

 else

   Print('Во втором числе больше цифр')

 end

end.


Паскаль, процедуры и функции Составить программу, определяющую, в каком из данных двух чисел больше
0,0(0 оценок)
Ответ:
nanakochieva72
nanakochieva72
27.08.2020 22:17

var x1,x2:integer;

function f(x:Integer):Integer ;

var

k:integer;

begin

while x>0 do

begin

x:=x div 10;

k:=k+1;

end;

f:=k;

end;

begin

read(x1,x2);

if f(x1)>f(x2) then

write('В первом числе больше цифр')

else if

f(x2)>f(x1) then

write('В втором числе больше цифр')

else

write('В числах одинаковое количество цифр')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?