В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
bbbbbbbbbb2
bbbbbbbbbb2
28.02.2020 16:54 •  Информатика

1. Напишите программу, которая заполняет массив из N = 8 элементов случайными числами
в диапазоне (0,10), выводит его на экран, а затем выводит на экран квадраты всех элементов
массива.
Пример:
Массив: 5 6 2 3 1 4 8 7
Квадраты: 25 36 491 16 64 49
.​

Ответ:
Kasha09
Kasha09
11.10.2020 15:47

C# 8.0:

using System;

...

var Arr = RandomIntArr(0,10,8);

foreach(int i in Arr) Console.Write(i+" ");

Console.WriteLine();

foreach(int i in Arr) Console.Write(i*i + " ");

...

static int[] RandomIntArr(int Min, int Max, int ArrLen) {

  Random rnd = new Random();

  int[] Out = new int[ArrLen];

  for (int i = 0; i < ArrLen; i++)  Out[i] = rnd.Next(Min, Max+1);

  return Out;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?