В
Все
Х
Химия
В
Видео-ответы
А
Алгебра
Г
Геометрия
О
ОБЖ
Д
Другие предметы
У
Українська література
Р
Русский язык
Б
Беларуская мова
У
Українська мова
Э
Экономика
Ф
Физика
М
Математика
Ф
Французский язык
Г
География
И
Информатика
М
МХК
О
Окружающий мир
П
Психология
Н
Немецкий язык
О
Обществознание
П
Право
И
История
М
Музыка
Л
Литература
Қ
Қазақ тiлi
Б
Биология
А
Английский язык
kris7510
kris7510
30.08.2022 13:12 •  Информатика

очень Написать программу в Pascal:
В одномерном МАССИВЕ введённом с клавиатуры определить сколько элементов имеет отрицательный индекс, сколько ненулевых элементов в массиве, рассчитать среднее значение положительных элементов.( Все эти условия должны быть в одной программе, и с массива)Если я буду очень благодарен

Ответ:
apologise
apologise
11.10.2020 12:52

program masss;

var

a:array[-5..5] of integer;

i,oi,n0,s: integer;

begin

oi:=0;n0:=0; s:=0;

for i:=-5 to 5 do

begin

read(a[i]);

if i<0 then inc(oi);

if a[i]<>0 then inc(n0);

if a[i]>0 then s:=s+a[i];

end;

writeln('элементы с отрицательным индексом》',oi);

writeln('ненулевых элементов в массиве》',n0);

writeln('среднее значение положительных элементов》',s/11);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?